myMPX
Advertisement


Go Back MyMPx.org > MyMPx.org Forum > Dead Players

DEAD!? I think we can fix this one!
Reply
Post New Thread
 
Thread Tools
  #1  
Old 1st Mar 2008, 1:35 pm
0meg4 0meg4 is offline
New Member
 
Join Date: Mar 2008
Posts: 5
Default DEAD!? I think we can fix this one!


Hi there.. ive been searching all aroun the "how to" forum.. and the "dead players" forum and havent find a real solution to this one..

Is a MP4 1GB Sigmatel Chip player..
The brand is "Titan" :roll:

It came like this from the store.. a friend just gave it to me and said that if i can fix it its mine! 8)

I already updated the firmware :idea: and is still the same.. Here are some pics and info: :arrow:

Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.

I appreciate any kind of help or hint of what to do with this..
Thanks
0meg4^
Reply With Quote
  #2  
Old 2nd Mar 2008, 6:21 pm
0meg4 0meg4 is offline
New Member
 
Join Date: Mar 2008
Posts: 5
Default

ANy responses?
__________________
Click the image to open in full size.
Reply With Quote
  #3  
Old 10th Mar 2008, 9:20 pm
0meg4 0meg4 is offline
New Member
 
Join Date: Mar 2008
Posts: 5
Default

**--BUMP--**
__________________
Click the image to open in full size.
Reply With Quote
  #4  
Old 17th Mar 2008, 3:00 pm
0meg4 0meg4 is offline
New Member
 
Join Date: Mar 2008
Posts: 5
Default Re: DEAD!? I think we can fix this one!

BUMP AGAIN!..

Please anyone just give me a clue or something,..
__________________
Click the image to open in full size.
Reply With Quote
  #5  
Old 28th Dec 2008, 5:58 pm
0meg4 0meg4 is offline
New Member
 
Join Date: Mar 2008
Posts: 5
Default Re: DEAD!? I think we can fix this one!

ANY ONE?
__________________
Click the image to open in full size.
Reply With Quote
  #6  
Old 29th Dec 2008, 12:17 am
wankausr wankausr is offline
New Member
 
Join Date: Dec 2008
Posts: 11
Default Re: DEAD!? I think we can fix this one!

your mp4 is just like mine and i still need a firmware
here is my post http://www.mympxplayer.org/need-firm...5-vt12014.html
Reply With Quote
  #7  
Old 29th Dec 2008, 2:07 pm
Alexandr Alexandr is offline
New Member
 
Join Date: Aug 2008
Posts: 8
Default Re: DEAD!? I think we can fix this one!

Maybe this help to you.
http://rapidshare.com/files/16926089...an_upgrade.rar
Reply With Quote
Sponsored Links
Reply

Sponsored Links

Thread Tools



All times are GMT -7. The time now is 1:45 pm.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Back to Top

Designed by indiqo.media