myMPX
Advertisement


Go Back MyMPx.org > MyMPx.org Forum > General Discussion

Modifying Series 11 (AK2025/ATJ2111/3/5) Device Research Thread
Reply
Post New Thread
 
Thread Tools
  #31  
Old 11th Feb 2010, 9:02 pm
jaf0 jaf0 is offline
New Member
 
Join Date: Jan 2010
Location: Midwest
Posts: 3
Default re: my chipod...


turns out it's a 2.0gb///

if you're stuck at the ADMINISTR 00 MB thing,

use the disktool to create an encrypted partition to bring the drive down to "real" size...

I had to make the partition 5954 MB and then the thing showed ...

ADMINSTR 1968 MB ...

that was the max.

one way of telling is if both "disks" re mount properly in explorer.

if you get the error USB device had problems message .. your encrypted partition isn't big enough ....

YMMV
Reply With Quote
  #32  
Old 22nd Feb 2010, 7:45 am
joaquimorg joaquimorg is offline
New Member
 
Join Date: Feb 2010
Posts: 1
Default Source Code

Hi can you share the changes you made to the s1giveio to read the version 11 !
Reply With Quote
  #33  
Old 2nd Apr 2010, 9:27 am
ivanleets ivanleets is offline
New Member
 
Join Date: Apr 2010
Posts: 2
Default

Hi Guys

Is this research still on going?

Please advise.

Thanks.
Reply With Quote
  #34  
Old 2nd Apr 2010, 8:37 pm
ivanleets ivanleets is offline
New Member
 
Join Date: Apr 2010
Posts: 2
Default

Here is my dump(see attachment). This dump is from my 2nd fake ipod (AK2025 16GB) which is still able to be detected by my PC.

For my 1st fake ipod (AK2025 16GB), my PC cannot detect this device and whenever connected with same USB cable, it keeps asking for USB driver. I tried ADFUUpdate.inf (from jaf0) but still no luck.

Please help.
Attached Files
File Type: zip dump8000_ivanleets_AK2025_16GB.zip (23.8 KB, 24 views)
Reply With Quote
  #35  
Old 29th Apr 2010, 10:02 pm
lolita lolita is offline
Senior Member
Valued Member
 
Join Date: Aug 2007
Posts: 1,240
Default

Alright, enough BROM dumps for now. I think we have more than enough.

I still have a ton of Series 9 research and documenting to do.
__________________
I am no longer affiliated with Actions Semiconductor Co. Ltd. Do not ask me for firmware.
Reply With Quote
  #36  
Old 3rd Apr 2011, 12:31 am
jabber jabber is offline
New Member
 
Join Date: Mar 2011
Posts: 1
Default

plz sir hellp me i need mp3 firmware.

Board id smd-atj2111 ver.1.1
Reply With Quote
  #37  
Old 8th Jan 2012, 1:31 am
amunro amunro is offline
New Member
 
Join Date: Jan 2012
Posts: 1
Default

This seems about the best thread to help me with a AK2025C nano clone.

When I press and hold the play button and plugin the usb, Windows sees the ADFU interface. I have loaded two different ADFU windows drivers and they seem to work. I have tried 3 different versions of s1giveio (v13/v14/the alpha version about which is dated 2009 and seems the latest). s1giveio just does not see the device. Device has an Apple icon on its display. Problem is with the internal flash; it was supposed to be a 4Gb device, but using the MP3 disk tool to test it, turns out its a 2Gb device. I resized it and it all seemed ok, but it would not keep its FAT32 disk layout; windows kept wanting to reformat, so maybe it needs to be slightly smaller? So I tried reformat under Linux, but from what I gather it needs to be encrypted. After the Linux reformat, unit fails to startup, but keeps rebooting. Guess its very unhappy about the disk format. So I want to dump its firmware and then try and fix its disk again.

Opened up the unit and it has the following chips in it:

Battery: 3.7V 140mAh Aman-302030
Main chip: AK2025C SA90QAC OIG
Flash: 1x Hynix H27UAG8T2ATR 16Gbit (2Gbyte; not 4Gb as per the sticker)
Radio chip: Comlent CL5767P
Goodix capacitive/touch sensitive chip.
Board: CB-2518-2-KEY CBD
FW version: 9.5.54.

Probably need a break from looking at this and to come back to it later, with a new approach

Also tried winxp-32 in virtualbox and win7 32bit. Also tried the s1res program to extract the firmware. Seems to be nothing can see the device, apart from Windows!

Last edited by amunro; 8th Jan 2012 at 1:34 am.
Reply With Quote
Sponsored Links
  #38  
Old 21st Sep 2012, 5:51 pm
rapierdragon rapierdragon is offline
New Member
 
Join Date: Mar 2009
Posts: 5
Default -- 2 years go by -- where is the update?

I just got a new 1" mp4 (ipod gen6 clone ?). Just bought off ebay, and it arrived off the mail truck last week (sept/2012).

It says it has 8 Gb storage. Doubt I'll ever use all of it. (I've got a nice old 3.7" mp4 that has an SD-card-slot which I use for vid-watching on the go).

Mainly I bought this 1" ch'ipod so I could clip it onto a watch-band and basically modify into custom LCD-display type watch. It would still have mp3/mp4 abilities... maybe a Star Trek TNG type LCARS display... but that's all unrelated to the main reason for this post.

I can't even start to hack the it cause no one anywhere has firmware support for series 11.

Data (as it shows from its menu):

2011/11/29
1.0.04
2011/12/02
as211a_v1003

and from easychip and chipgenius I get:

actions hs usb flashdisk
atj211x

As you can see, its one of these "relatively new" series 11 chips.

BUT THE ONLY INFO I CAN FIND on where the research is going is easily dated 2010 or so.

As you can imagine, it's now September 2012. Where are our updates? Did it turn out that the new chip setup completely prevents you from updating something like s1res to work with the new series 11?

-- my guess on the old system (v3~v9) vs new system (series 11)

I'm guessing the new format is quite different from the older versions. Originally you had only what, one chip to deal with? It had two sections to it, the firmware (the menu, graphics to display menu, battery-charge level graphic, etc), and the user-accessable storage area (for mp3/mp4/jpg/txt type files).

And the new setup must be almost like having two chips; one with firmware, one with storage and a compression algorithm; and the second chip has all the storage. That would explain why my mp4 has TWO dates listed for firmware.

Anything windows sends or receives probably basically goes to the first chip, gets compressed (or uncompressed) and then stored on the second chip. Guessing there's no direct access to the first chip (its been specifically built and coded to sit like an invisible piece of glass to the end-user. Only the manufacturer is supposed to know how to access it.)

Even if its still mainly one chip, it acts like two chips. Windows XP/Vista shows the device as being hacked to show 8 GB storage, but then if you format it it'll show only 2 GB ... cause basically the "hidden chip" acts like a tiny 7-zip (or winrar/winzip) type program (from our point of view).

So okay, maybe in reality the new series 11 doesn't really work that way, but I'm just trying to give an easy-to-understand basic-picture type explanation. It would also explain why so many ppl have "delay" issues with load-times and "crash/stall" issues with larger files... cause the file needs to decompress to play, basically get unzipped and temporarily-stored in the free space. (Would explain why a 30-second video plays fine, but the moment you try to save or load a 1+ gig video to the supoosed 8 gig storage the device has problems... its kind of like the old "not enough free RAM" issues we had back in the old 386/486 cpu days.)

Flash memory isn't the same as RAM memory. It won't matter if your mp4 has 16 gig of flash storage if its only got a tiny 640 mb of ram (exagerating here, but you get the idea. Would be a bit like trying to read the data off a DVD with only your own eyes instead of using a DVD-player to decompress/decode it and TV to display it).

-- oops, sorry ---

Lol, didn't mean to go on so long. Sometimes I just get a great idea and it comes out in that "sounds a bit like a rant" effect when I try to explain it.

Anyways ... updates?
Reply With Quote
  #39  
Old 26th Jun 2013, 8:36 am
Marco Marco is offline
New Member
 
Join Date: Jun 2013
Posts: 2
Default

http://mympx.org/forum/289458-post1.html

here a link to a firmware that maybe can be crossflashing to an other player...

unfortunately s1res can't open it any suggestions?
Reply With Quote
Reply

Tags
ak2025, atj2111, atj2113, atj2115, series 11

Sponsored Links

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is the s1clone thread? SayNoMore Support and How To 1 9th Jul 2007 4:42 pm
Modifying player with 9.1.50 FW? I_SAY Mods and Themes 14 6th Jul 2007 7:39 am
modifying firmware xeongx Mods and Themes 13 14th Dec 2006 9:48 am
modifying my original FW raz Support and How To 2 4th Sep 2006 7:11 pm
The noob thread Lorne Support and How To 8 4th Sep 2006 7:00 am


All times are GMT -7. The time now is 4:53 am.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Back to Top

Designed by indiqo.media